Warum registrieren? Nur als registriertes Mitglied vom ABAKUS Forum hast Du vollen Zugriff auf alle Funktionen unserer Website.

Wordpress Blog SSL (Lets Encrypt) zu viele redirects

Informationen & SEO Tipps zum Einsatz und Verwendung von Blog-, Wiki und Content Management Systemen wie Drupal, Typo3, Wordpress, Reddot, Joomla, Moin Moin, phpWiki sowie Shop-Systemen wie z.B. XT-Commerce, Magento, ePages, Intershop, 1&1 Shops.
Myrtus
PostRank 4
PostRank 4
Beiträge: 113
Registriert: 05.02.2015, 14:11

Beitrag von Myrtus » 05.02.2019, 09:40

Moin ihr, kann mir mal wieder bitte wer helfen?

Ich habe erst gerade mein Wordpress Blog auf https umgestellt via All-Inkl mit Let´s Encrypt.

Hat auch alles geklappt aber gtmetrix und Pingdom Speed Test etc. warnt das es sehr viele Redirects gibt jeweils von www zu https://www ?

Ich hatte in Wordpress in den allgemeinen Einstellungen auf https:// die Adresse geändert. In der Search Console habe ich die https Properties angelegt.

Was kann ich tun damit diese Warnung mit den Redirects nicht mehr kommt oder is das normal?

ABAKUS Anzeige

von ABAKUS Anzeige »





SEO Consulting bei ABAKUS Internet Marketing.
Nutzen Sie unsere jahrelange Erfahrung und lassen Sie sich beraten!
Jetzt anfragen unter: SEO Consulting oder kontaktieren Sie uns direkt unter: 0511 / 300325-0


Hanzo2012
Community-Manager
Community-Manager
Beiträge: 1748
Registriert: 26.09.2011, 23:31

Beitrag von Hanzo2012 » 05.02.2019, 10:32

Schau dir mal den Quellcode deiner Seite an (Strg+U). Gibt es da noch irgendwelche http-Verweise? Z. B. Bilder, Stylesheets oder JavaScript-Dateien?

staticweb
PostRank 9
PostRank 9
Beiträge: 1542
Registriert: 04.05.2016, 14:34

Beitrag von staticweb » 05.02.2019, 10:53

> Ich habe erst gerade mein Wordpress Blog auf https umgestellt via All-Inkl mit Let´s Encrypt.

Was hat das Problem mit Let´s Encrypt zu tun? Nichts!

Du hast garantiert alte Weiterleitungen in der htaccess und die Links im content nicht mit angepasst.

Myrtus
PostRank 4
PostRank 4
Beiträge: 113
Registriert: 05.02.2015, 14:11

Beitrag von Myrtus » 07.02.2019, 11:56

staticweb hat geschrieben:>
Was hat das Problem mit Let´s Encrypt zu tun? Nichts!

Du hast garantiert alte Weiterleitungen in der htaccess und die Links im content nicht mit angepasst.

Ja das kann sein mit den Weiterleitungen...

Das liegt neben Let´s Encrypt auch nicht an Wordpress :) ich meinte ja nur das ich auf SSL umgestellt habe ich kann auch einfach sagen SSL & Blog ohne WP & Let´s Encrypt :)

Also muss ich jetzt in der htaccess irgendwas ändern?

Die Links im Content sind alle mit https verlinkt das hatte "mein Content Management System" :D automatisch gemacht

heinrich
PostRank 9
PostRank 9
Beiträge: 2849
Registriert: 17.08.2006, 11:26

Beitrag von heinrich » 07.02.2019, 17:19

Myrtus hat geschrieben:Die Links im Content sind alle mit https verlinkt das hatte "mein Content Management System" :D automatisch gemacht
Da wäre ich bei WP nicht so sicher - installier dir einmal das Plugin Better Search Replace und ändere einmal damit alle http://URL auf https://URL.

Und schau, ob in der htaccess das steht:

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteCond %{HTTP_HOST} URL$
RewriteCond %{HTTPS} !=on
RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [R=301,L]
</IfModule>

staticweb
PostRank 9
PostRank 9
Beiträge: 1542
Registriert: 04.05.2016, 14:34

Beitrag von staticweb » 07.02.2019, 18:05

> Die Links im Content sind alle mit https verlinkt das hatte "mein Content Management System" automatisch gemacht

Falsch gedacht. Es werden nur die System-Links, wie z.B. Menüs, angepasst, aber nicht der user generierte content.

Antworten
  • Vergleichbare Themen
    Antworten
    Zugriffe
    Letzter Beitrag